Appendix A
Data Analysis with Excel
Computers are used for data analysis in any modern physics laboratory, and the Physics
103 lab is no exception. We have built our data analysis system around the program Excel,
which is widely used on and oﬀ campus. We’ve added some Workshop Physics (WP) tools to
make graphing data easier, and to let you do regression calculations with uncertainties, but
otherwise we are using the standard, oﬀ-the-shelf software.1
If you are already familiar with Excel, great! If not, we’ll give brief instructions here.
Like any software, it can be confusing at ﬁrst, so don’t hesitate to ask your instructors and
your fellow students for help. Play around with the program a bit to get comfortable with
it.

A.1

Starting Things Up

• If the computer isn’t already on, turn it on and wait for it to boot up.
• If the Physics 103 window isn’t already open, double click on the Physics 103 icon to
open it
• Double click on Excel with WPtools (look for the X logo) to get the program running.

A.2

Entering Data: a Simple Example1

When Excel is started up, you need to open a spreadsheet to work in. If you are asked if
you want to reopen WPtools, click No. Then go to File→New and click on OK to open a new
Workbook. (If you wanted to open a pre-existing spreadsheet, you would use the File→Open
menu command; if you want to save the new spreadsheet, use the File→Save menu command.
Since we’ll be working with fairly small datasets, neither of these is really necessary for your
lab work.)
Suppose you wish to record some (x, y) data pairs in two columns of a spreadsheet. Go
to Excel, and start entering the data in the upper left most cell (called A1). To do this, move
the cursor to this cell and click on it with the left mouse button. Enter the ﬁrst x data value
1

Some online documentation for WPtools is at
http://physics.dickinson.edu/~wp_web/wp_resources/Documentation.html
1
Note: Menu commands are described as follows: File→Open means move the cursor to the word File on
the line near the top of the screen, press and hold the left mouse button, drag the cursor down to the word
Open, and release the button.
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here, pressing Return when you are done. The cell below it (called A2) will automatically be
selected next; enter the second x data value here. Work down the ﬁrst data column in this
way. If you need to go back and correct any of the numbers, simply move the cursor with
the mouse, click on the relevant cell, and re-enter the number.
Once you’ve entered the ﬁrst column of numbers, move the cursor to the top cell of the
second column (cell B1) and click the left button to select it. Enter the ﬁrst y data value.
Press Return/Enter, and enter subsequent y data in the rest of the cells.

A.3

Calculations in Excel

Now that your two columns of data are in the computer, select them. Do this by moving the
cursor to the top left cell, pressing and holding the left mouse button, dragging the cursor to
the lowest ﬁlled cell in the second column, and then releasing the mouse button. The block
of numbers you entered will now be “selected”, indicated by a blue-grey color.
Go to the WPtools pull-down menu and select Linear Fit. Immediately Excel will display
a plot of your data, along with the values and uncertainties of the best-ﬁt line. Print out a
copy of the results if desired.2
Sometimes you will want to transform your raw data in some way before plotting it. For
example, you may have entered two columns of data as above, but you want to convert the
y values from inches to meters. This is where a spreadsheet program becomes really handy.
Select a blank cell somewhere on the sheet (cell C1 would be a good place). Instead of
entering a number, enter the formula ‘=0.0254*B1, and press Return. Excel will display the
expected numerical value in cell C1, and it will also remember the formula. This is useful
for two reasons, ﬁrst, if you change the value in B1, the number in C1 will be automatically
updated. Second, you can copy the formula in C1 to other cells, transforming the rest of
column B using the same formula. To do this, ﬁrst select cell C1. The cell becomes outlined,
and note that there is a little square in the lower right corner of the outline. Move the cursor
to this square, push and hold the left mouse button, drag the cursor down several cells, and
release the mouse button. Voila! Excel will use the same formula to multiply all the cells in
column B by 0.0254.
Excel can do much more complicated arithmetic. For example, you could use the formula
=sqrt(A1) * B1 to take the square root of the values of cells in column A, multiply them by
the values in column B, and put the result in some other column.
You might also want to take diﬀerences between the successive items in your data list. If
you type into cell C2 the formula =B2-B1, and then use the little square to ﬁll this formula
into the cells B3, B4, etc., then you will obtain the diﬀerences in column C.
If you do a transformation like this, and then you want to do a plot or a curve ﬁt, the
columns of data you want to plot may not be adjacent to each other. No problem. Say you
want to plot cells A1-A10 on the horizontal axis and cells C1-C10 on the vertical axis. First
2

You must first “grab” the plot by left-clicking on an open area inside it. If the plot legends are obscuring
the graph, drag them aside with the mouse. Your can add labels to your plot using the Edit labels option on
the WPtools menu bar.
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select A1-A10. (Go to cell A1, hold down the left button, drag the cursor to A10, then release
the mouse button). Then hold down the Ctrl key and select C1-C10. Now both cell groups
A1-A10 and C1-C10 will be selected, but not B1-B10. Run the WPTools→LinearFit routine,
and you will get the plot you want.

A.4

Accumulating Values via Excel Tricks

There will be times in the Physics 103 lab when you want to accumulate sums of a series of
values. For example, you might have measured a series of time intervals,
Δt1 = interval between event 1 and event 2,
Δt2 = interval between event 2 and event 3,
Δt3 = interval between event 3 and event 4,
etc.
You may wish to convert these into a continuous time scale. In other words, you may want
to declare that t = 0 at the time of event 1, and then ﬁnd
time of event 2 = Δt1,
time of event 3 = Δt1 + Δt2,
time of event 4 = Δt1 + Δt2 + Δt3,
etc.
This is easy to do. Say that Δt1, Δt2, etc., are in cells A1, A2, etc., and you want to put
the accumulated times in column B. First put a 0 in cell B1 (since t = 0 for the ﬁrst event).
Then go to cell B2 and enter the formula =SUM($A$1:A1). The SUM function simply adds
up the cells in the range speciﬁed.
The usefulness of the $ notation becomes apparent when you want to calculate the rest
of the times. Select B2, move the cursor to the square in the lower righthand corner of the
cell border, press and hold the left mouse button, drag the cursor down several cells, and
release the button. The cells in column B are now ﬁlled with SUM functions, but in a special
way: The $A$1 in the SUM function call remains the same in all the cells (because of the
$), but the second part of the function call changes from A1 to A2 to A3, ... In other words,
cell B3 now reads =SUM($A$1:A2), cell B4 reads =SUM($A$1:A3), and so on. These are
exactly the formulae we want for the event time calculations, so column B is now ﬁlled with
calculated values of t.

A.5

Further Notes about Workshop Physics Routines

• Use the WPtools→Polynomial Fit menu command, and set Order=2 to ﬁt lines of the
form y = c0 + c1 x + c2x2 .
• If you enter non-numerical text in the cell above each column of data, it will be used
to label the horizontal and vertical axes on the plot.
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• The ﬁtting routines always use the ﬁrst selected column for the horizontal (x) points,
and the second selected column for the vertical (y) points.
• Empty rows are usually ignored (but partially-empty rows may corrupt the ﬁt).
• To delete a plot, select it (move cursor to it and click once), then press the Delete key.
To delete a column of the sheet, select the entire column (by clicking on the letter at
the top) and use Edit→Delete.
• If data are modiﬁed after running a ﬁt, the associated plot will be automatically updated, but the ﬁt parameters will not be re-calculated. Usually it is best to delete both
the old plot and ﬁt parameters after updating data.

Appendix B
Estimation of Errors
While the subject of error analysis can become quite elaborate, we ﬁrst emphasize a basic
but quite useful strategy, discussed in secs. B.1-2. Then, we distinguish between random (or
statistical uncertainties and systematic uncertainties in sec. B.3. Random uncertainties follow
the famous bell curve, as sketched in secs. B.4-5. The important distinction between the
uncertainty on a single measurement, and the uncertainty on the average of many repeated
measurements is reviewed in secs. B.7-7. The subject of propagation of errors on measured
quantities to the error on a function of those quantities is discussed in sec. B.8.

B.1

67% Confidence

Whenever we make a measurement of some value v, we would also like to be able to say that
with 2/3 probability the value lies in the interval [v − σ, v + σ]. We will call σ the uncertainty
or error on the measurement. That is, if we repeated the measurement a very large number
of times, in about two thirds of those measurements the value v would be in the interval
stated.

B.2

A Simple Approach

Repeat any measurement three times, obtaining a set of values {vi }, i = 1, 2, 3. Report the
average (mean),
N
1 
vi
(for N = 3),
(B.1)
v̄ =
N i=1
as the best estimate of the true value of v, and the uncertainty σ as
σ=

vmax − vmin
.
2

(B.2)

If you take more than three measurements, you can still implement this procedure with
the aid of a histogram. Divide the range of observed values of v into 5-10 equal intervals
(called bins). Located the bin that contains each measurement, and draw a box one unit
high above that bin. Stack the boxes on top of one another if more than one measurement
falls in a bin. To estimate the error, determine the interval in v that contains the central 2/3
of the measurements, i.e., the central 2/3 of the boxes you just drew, and report the error
as 1/2 the length of this interval.
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Random and Systematic Uncertainties

The uncertainty in a measurement of a physical quantity can be due to intrinsic random
uncertainty (colloquially: error) as well as to systematic uncertainty.
Random uncertainties lead to diﬀerence in the values obtained on repetition of measurements. Systematic uncertainties cause the measurement to diﬀer from its ideal value by the
same amount for all repetitions of the measurement.
Random uncertainties can arise from vibrations of the components of a set-up driven by
random thermal ﬂuctuations, random noise in the electronics, and/or many other small but
uncontrolled eﬀects including quantum ﬂuctuations.
In principle, the eﬀect of random uncertainties can be made as small as desired by
repetition of the measurements, such that the dominant uncertainty is due to systematic
eﬀects (which can only be reduced by designing a better measurement apparatus).

B.4

The Bell Curve

In many cases when a measurement is repeated a large number of times the distribution of
values follows the bell curve, or Gaussian distribution:
2

2

e−(v−μ) /2σ
√
P (v) =
,
2πσ

(B.3)

where P (v)dv is the probability that a measurement is made in the interval [v, v + dv], μ
is true value of the variable v, and σ is the standard deviation or uncertainty in a single
measurement of v. See Figure B.1.

Figure B.1: The probability distribution measurements of a quantity with true value μ and
Gaussian uncertainty σ of a singe measurement. About 68% of the measurements would fall
in the interval between μ − σ and μ + σ, and 95% would fall in the interval μ ± 2σ.
The Table lists the conﬁdence that a single measurement from a Gaussian distribution
falls within various intervals about the mean. If the 100 students in Ph103 each make 100
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Table B.1: The probability (or conﬁdence) that a measurement of a Gaussiandistributed quantity falls in a speciﬁed interval about the mean.
Interval Conﬁdence
±σ
±2σ
±3σ
±4σ

68%
95%
99.7%
99.994%

measurements during these lab sessions, then 10,000 measurements will be taken in all. The
Table tells us that if those measurements have purely Gaussian ‘errors’, then we expect one
of those measurements to be more than 4σ from the mean.

B.5

Estimating Uncertainties When Large Numbers of
Measurements Are Made

One can make better estimates of uncertainties if the measurements are repeated a larger
number of times. If N measurements are made of some quantity resulting in values vi , i =
1, ...N then the mean is, of course,
v̄ =

N
1 
vi ,
N i=1

(B.4)

and the standard deviation of the measurements is
σ=






N
1 
(vi − v̄)2.
N − 1 i=1

(B.5)




Calculus experts will recognize that the operation (1/N) N
i=1 becomes P (v) dv in the limit
of large N. Then, using the Gaussian probability distribution (B.3) one veriﬁes that
v̄ = v =

B.6

 ∞
−∞

vP (v) dv,

and

σ 2 = (v − v̄)2 =

 ∞
−∞

(v − v̄)2 P (v) dv.

(B.6)

The Uncertainty on Mean of a Uniformly
Distributed Quantity

Not all measurable quantities follow the Gaussian distribution. A simple example is a quantity with a uniform distribution, say with values v equally probable over the interval [a, b].
It is clear that the average measurement would be (a + b)/2, but what is the uncertainty
of the measurement? If we adopt the simple prescription advocated in secs. B.2 we would
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report the uncertainty as (b − a)/3 since 2/3 of the time the measurement would fall in an
interval 2(b − a)/3 long. If instead we use the calculus prescription for σ given in eq. (B.6)
we ﬁnd that
b−a
b−a
=
,
(B.7)
σ= √
3.46
12
which result is often used by experts.

B.7

The Uncertainty in the Mean

Thus far we have considered only the uncertainty or spread in measured values of some
quantity v. A related but diﬀerent question is: what is the uncertainty on our best estimate

of v (which is just the mean value of our measurements, v̄ = (1/N) vi )?
The uncertainty on the mean v̄ is surely less that the uncertainty, σ, on each measurement
vi . Indeed, the uncertainty on the mean is given by
σ
σv̄ = √ ,
(B.8)
N
where σ is our estimate of the measurement error obtained from one of the methods sketched
previously.
Appendix C illustrates eq. (B.8) using measurements of g from past Ph103 labs.

B.8

The Uncertainty on a Function of Several
Variables (Propagation of Error)

In many cases we are interested in estimating the uncertainty on a quantity f that is a
function of measured quantities a, b, ... c. If we know the functional form f = f(a, b, ...c)
we can estimate the uncertainty σf using some calculus. As a result of our measurements
and the corresponding ‘error analysis’ we know the mean values of a, b, ... c and the error
estimates σa , σb , ... σc of these means. Our best estimate of f is surely just f(a, b, ...c) using
the mean values.
To estimate the uncertainty on f we note that the change in f due to small changes in
a, b, ... c is given by
∂f
∂f
∂f
Δa +
Δb + ... +
Δc.
(B.9)
Δf =
∂a
∂b
∂c
If we just averaged this expression we would get zero, since the ‘errors’ Δa, ... Δc are sometimes positive, sometimes negative, and average to zero. Rather, we square the expression
for Δf, and then average.
2

Δf =

∂f
∂a

2

∂f
Δa + ... +
∂c
2

2

Δc2 + ... + 2

∂f ∂f
ΔaΔc + ...
∂a ∂c

(B.10)

On average the terms with factors like ΔaΔc average to zero (under the important assumption that parameters a, b, ... c are independent). We identify the average of the squares of
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the changes relative to the mean values as the squares of the errors: Δa2 = σa2, etc. This
leads to the prescription
σf2

=

∂f
∂a

2

σa2

2

∂f
+ ... +
∂c

σc2 + ...

(B.11)

Some useful examples are
f = a ± b ± ... ± c

⇒

σf =

σa2 + σb2 + ... + σc2,

(B.12)

and
f = albm ...cn

⇒

σf
=
f



l2



σa
a

2

+ m2



σb
b

2

+ ... + n2



σc
c

2

,

(B.13)

where l, m and n are constants that may be negative.
For more detailed and rigorous analyses one can consult, for example:
• P.R. Bevington and D.K. Robinson, Data Reduction and Error Analysis for the Physical
Science, 2nd ed. (McGraw-Hill, New York, 1992).
• J.R. Taylor, An Introduction to Error Analysis: The Study of Uncertainties in Physical
Measurements, 2nd ed. (University Science Books, 1997).

Appendix C
Standard Deviation of the Mean of g
Suppose you make N repeated measurements of a quantity g, such as the acceleration due
to gravity. How well is the value of g determined by these measurements?
For example, during the 2006 sessions of Ph103 Lab 6 a total of 37 diﬀerent measurements
of g were made, as shown in the histogram Fig. C.1.

Figure C.1: Histogram of the values of g measured in the 2006 Ph103 Lab 3. The horizontal
axis is g, and the vertical axis is the number of times a value of g was reported to lie with
the range of g corresponding to the width of a vertical bar.
A histogram is a graph containing M vertical bars in which the height of a bar indicates
the number of data points whose value falls within the corresponding “bin”, i.e., within
the interval [gj − Δ/2, gj + Δ/2], where gj , j = 1, M and the centers of the M bins and
Δ is the bin width. One can make a histogram of a data set {gi } using Excel/Tools/Data
Analysis/Histogram. Enter the data {gi } in one column of an Excel spreadsheet. Click on the
Input Range: box of the Histogram window; then click and hold the left mouse button on the
ﬁrst data point, and drag the mouse to the last data point to enter the cell addresses of the
data. Click on Chart Output and then OK to create a basic histogram. If the number/spacing
of “bins” chosen by Excel is awkward, ﬁll a new column with a linear series of 5-10 steps
that begins near the lowest gi and ends near the highest; create a new histogram with the
Excel addresses of the ﬁrst and last elements of the bin list in the box Bin Range:.
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The mean value ḡ is calculated according to
N

ḡ =

i=1

gi

N

,

(C.1)

and was found to be ḡ = 939.5 cm/s2 for the data shown in Fig. C.1.
The distribution of the value of g is approximately Gaussian, and the standard deviation
of this distribution is calculated according to


σg =

N
i=1 (gi

− ḡ)2
,
N −1

(C.2)

with the result that σg = 9.1 cm/s2.
The standard deviation σg is a good estimate of the uncertainty on a single measurement
of g. However, after 37 measurements of g, the uncertainty on the mean value ḡ is much
smaller than σg .
An important result of statistical analysis is that the standard deviation (i.e., the uncertainty) of the mean of the N measurements is related to the standard deviation of the
distribution of those measurements by,
σg
σḡ = √ .
N

(C.3)

For the data shown in Fig. C.1, where N = 37, we obtain
9.1
σḡ = √ = 1.5 cm/s2 .
37

(C.4)

That is, we can report the result of all 37 measurements of g as
g = 979.5 ± 1.5 cm/s2 .

(C.5)

As a check that eq. (C.3) is valid, we can analyze the data another way. Namely, we can
ﬁrst calculate the means ḡi for the 5 diﬀerent sessions of Ph103 Lab 3. Then, we can make
a histogram of these 5 values, as shown in Fig. C.2.
The mean of the 5 means is 979.6 cm/s2 , which is essentially identical to the mean of the
37 individual measurements of g. The standard deviation of the 5 means shown in Fig. C.2
is calculated to be 1.6 cm/s2, which is essentially identical to the previous calculation (C.4)
of the standard deviation of the mean.
Concluding Remarks: If N were much larger than what we have here, the histogram
C.1 would approach the Gaussian distribution (the bell-curve) shown in Appendix B. The
peak in the histogram would be very close to the mean value ḡ of the measurements, which
represents the best estimate of g from the data. The standard√deviation σg ≈ width/2 is a
measure of the uncertainty of a single measurement,1 while σg / N is the uncertainty on the
best estimate ḡ.
1

Strictly speaking, the full width at half maximum of a Gaussian distribution is 2.35σg .
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Figure C.2: Histogram of the mean values of g measured in the 5 sessions of Ph103 Lab 6
in 2006.

Appendix D
Polynomial Fits in WPtools
D.1

Polynomial Regression

In this technical Appendix we sketch the formalism used in the polynomial regression method
for ﬁtting data. This is a generalization of the method of linear regression.
We start with a set of data (xj , yj ), j = 1, ...m, and we wish to ﬁt these data to the
nth-order polynomial
y(x) =

n


a i xi .

(D.1)

i=0

In general each measurement yj has a corresponding uncertainty σj . That is, if the measurements were repeated many times at coordinate xj the values of yj would follow a gaussian
distribution of standard deviation σj . We indicate in sec. D.2 how the program WPtools
proceeds in the absence of input data as to the σj .
Because of the uncertainties in the measurements yj we cannot expect to ﬁnd the ideal
values of the coeﬃcients ai, but only a set of best estimates we will call âi. However, we will
also obtain estimates of the uncertainties in these best-ﬁt parameters which we will label as
σâi .
The best-ﬁt polynomial is then
ŷ(x) =

n


âi xi .

(D.2)

i=0

The method to ﬁnd the âi is called least-squares ﬁtting as well as polynomial regression
because we minimize the square of the deviations. We introduce the famous chi square:




m
yj − ni=0 âixij
[yj − ŷ(xj )]2 
2
χ =
=
σj2
σj2
j=1
j=1
m


2

.

(D.3)

Fact: exp(−χ2/2) is the (un-normalized) probability distribution for observing a set of variables {yj (xj )} supposing the true relation of y to x is given by eq. (D.2).
A great insight is that exp(−χ2/2) can be thought of another way. It is also the (unnormalized) probability distribution that the polynomial coeﬃcients have values ai when
their best-ﬁt values are âi with uncertainties due to the measurements {yj }. Expressing this
in symbols,
n 
n

(ak − âk )(al − âl )
,
(D.4)
exp(−χ2/2) = const × exp −
2
2σkl
k=0 l=0
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or equivalently

n 
n


2

χ /2 = const +

k=0 l=0

(ak − âk )(al − âl)
.
2
2σkl

(D.5)

The uncertainty on âk is σkk in this notation. In eqs. (D.4) and (D.5) we have introduced the
important concept that the uncertainties in the coeﬃcients âk are correlated. That is, the
2
quantity σkl
is a measure of the probability that the values of ak and al both have positive
2
can be negative indicating that when ak has a
ﬂuctuations at the same time. In fact, σkl
positive ﬂuctuation then al has a correlated negative one.
One way to see the merit of minimizing the χ2 is as follows. According to eq. (D.5) the
derivative of χ2 with respect to ak is
n
al − âl
∂χ2/2 
=
,
2
∂ak
σkl
l=0

(D.6)

so that all ﬁrst derivatives of χ2 vanish when all al = âl. That is, χ2 is a minimum when
the coeﬃcients take on their best-ﬁt values âi . A further beneﬁt is obtained from the second
derivatives:
1
∂ 2χ2/2
= 2.
(D.7)
∂ak ∂al
σkl
In practice we evaluate the χ2 according to eq. (D.3) based on the measured data. Taking
derivatives we ﬁnd


m
yj −
∂χ2/2 
=
∂âk
j=1

and

n

i=0

âi xij



−xkj

σj2



=

n 
m

âixij xkj
i=0 j=1

σj2

−

m

yj xkj
j=1

m
xkj xlj
∂ 2χ2/2 
=
≡ Mkl .
∂âk ∂âl j=1 σj2

σj2

,

(D.8)

(D.9)

To ﬁnd the minimum χ2 we set all derivatives (D.8) to zero, leading to
m

xij xkj
yj xij
â
=
≡ Vk .
i
2
2
i=0 j=1 σj
j=1 σj

m
n 


(D.10)

Using the matrix Mkl introduced in eq. (D.9) this can be written as
n


Mik âi = Vk .

(D.11)

i=0

We then calculate the inverse matrix M −1 and apply it to ﬁnd the desired coeﬃcients:
âk =

n

l=0

Mkl−1 Vl .

(D.12)

Comparing eqs. (D.7) and (D.9) we have
1
= Mkl .
2
σkl
The uncertainty in best-ﬁt coeﬃcient âi is then reported as
1
.
σâi = σii = √
Mii

(D.13)

(D.14)
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Procedure When the σj Are Not Known

This method can still be used even if the uncertainties σj on the measurements yj are not
known. When the functional form (D.1) correctly describes the data we claim that on
average the minimum χ2 has value m − n − 1.1 To take advantage of this remarkable result
we suppose that all uncertainties σj have a common value, σ. Then
χ2 =

m


[yj − ŷ(xj )]2
≈ m − n − 1,
σ2
j=1

so that



σj = σ =

m
j=1 [yj

(D.15)



− ni=0 âi xij ]2
.
m−n−1

(D.16)

In practice it appears that the error estimates from this procedure are more realistic if a
ﬁt is made using a polynomial with one order higher than needed for a ‘good’ ﬁt to the data.
Using eq. (D.16) as the estimate of the uncertainty σ on each of the measurements yj ,
the matrix Mkl of eq. (D.9) becomes
m

m−n−1
Mkl = m
xkj xlj .
n
 2
i
j  =1 [yj  −
i =0 âi xj  ] j=1

(D.17)

The estimate (D.14) of the uncertainty on the ﬁt coeﬃcient âi is now given by





n
i 2
 m
1
j  =1 [yj  −
i =0 âi xj  ]
σâi = √
=
m
(m − n − 1) j=1 x2i
Mii
j


(D.18)

When WPtools performs a polynomial regression it generates a plot of the data points
and the best-ﬁt curve, along with numerical values of various parameters associated with the
ﬁt. Figure D.1 gives an example of a ﬁt to a set of 8 data points of the form y = x2. The
ﬁt is to the form y = a0 + a1 x + a2 x2 . The ﬁt coeﬃcients are a0 = −0.4107, a1 = −0.3274
and a2 = 1.1964. The uncertainties (standard errors) on the ﬁt coeﬃcients are reported as
SE(a0 ) = 4.0070, SE(a1 ) = 2.0429 and SE(a2 ) = 0.2216, as calculated according to eq. (D.18).
Note that the uncertainties on coeﬃcients a1 and a1 are larger than the coeﬃcients themselves, which tells us that these coeﬃcients are indistinguishable from zero.
Also indicated on the plot are the values R2 = 0.9915 and σ = 2.8721. The latter is the
uncertainty in the data points {yj }, calculated according to eq. (D.16) with m = 8 and
n = 2. The quantity R2 is deﬁned by
2

R =


m

j=1 [ŷ(xj )
m
j=1 [y(xj )

− y]2
,
− y]2

(D.19)

where the average y = m
j=1 y(xj )/m. This is a measure of the “goodness of ﬁt”. If the ﬁt is
perfect then ŷj = yj for all j and R2 = 1. It is not obvious, but R2 ≤ 1 always. The extreme
case of R2 = 0 occurs when the ﬁt has the trivial form ŷ(x) = y for all x, which in general is
a bad ﬁt. The qualitative conclusion is that if R2 is not close to 1, the ﬁt results are to be
regarded with suspicion.
1

The whole fitting procedure does not make sense unless there are more data points (m) than parameters
(n + 1) being fitted.
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Figure D.1: Sample plot from WPtools Polynomial Fitting.

